import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class-(\\d{2}) #Matches class, makes sure that class only is 2 digits - captures class digits\n"
+ "\\/([^\\/]{3}) #captures first 3 characters that aren't a slash.\n"
+ "\\/([^\\/]{3}) #Capture 3 characters again.\n"
+ "\\/([^\\/]{2}) #captures two characters\n"
+ "\\/([^\\/]{3}) #Captures 3 characters\n"
+ "\\/things_to_remember\\/ #Matches last piece of string.";
final String string = "class-11/xxx/xxx/xx/xxx/things_to_remember/\n"
+ "class-12/xxx/xxx/xx/xxx/things_to_remember/\n"
+ "xxx/class-11/xxx/\n"
+ "class-11/xxx/things_to_remember/xxx\n"
+ "class-11/xxx/";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}