#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mis)((?:^\s{0,3}(?:Supp[lemntaryl]*\s+)?(?:Tab[les]*)(?![^\n]{0,40}(?:show[s]?\b|describes?\b|lists?\b|depicts?\b|explains?\b|represents?\b|summariz?s?es?\b|is\sa\b|ill?ustrates?d?)).*?(?:\n{1}|\n\s+)))|((?:^\s{0,3}(?:Supp[lemntaryl]*\s+)?(?:Tab[les]*)\s\w+\s*\n{1,3}))"
Local $sString = "attraction model has 504% higher average power density than X-attraction model, and Y-repulsion model has 181% higher average power density than X-repulsion model. On the other hands, attraction case has higher electrical output than repulsion case. Y-attraction model has 328% higher average power density than Y-repulsion model, and X-attraction model has 117% higher average power density than X-repulsion model. The difference between X-attraction model and X-repulsion model was small because the value of power density was low. However the huge power density increase was measured in Y-attraction model from Y-repulsion model. The maximum power density was 54.96 µW/cm3 at 300 kΩ in Y-attraction model. Therefore, we can conclude that the Y-attraction model is optimized model for the piezoelectric energy harvesting system with magnetic pendulum movement. " & @CRLF & _
" " & @CRLF & _
" Table 3. Average Power Density along 4 Conditions" & @CRLF & _
"Pendulum direction Magnetic force Average power density (µW/cm3)" & @CRLF & _
"Y attraction 17.9" & @CRLF & _
"Y repulsion 5.45" & @CRLF & _
"X attraction 3.55" & @CRLF & _
"X repulsion 3.01" & @CRLF & _
"" & @CRLF & _
"Table 2 " & @CRLF & _
"Relative Synonymous codon usage of native and optimized HCV E2 gene" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"Figure 8. The Result of Power Density Increase Rate toward the Conventional Cantilever System along Pendulum Direction" & @CRLF & _
" " & @CRLF & _
"Figure 8 shows the power density increase rate of two attraction model toward the conventional cantilever beam piezoelectric energy harvesting system. In Y-attraction "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")