import re
regex = re.compile(r"^([abcd])(?:(?!\1)([abcd]))?(?:(?!\1|\2)([abcd]))?(?:(?!\1|\2|\3)([abcd]))?$", flags=re.MULTILINE)
test_str = ("abcd\n"
"abc\n"
"aaa\n"
"ab\n"
"a\n"
"abb\n"
"abcb\n"
"dbca\n"
"dbda\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")