$re = '/(foobar--[^\s]+)/';
$str = 'NAME ZONE STATUS ACTION LAST_ERROR
foobar--docker-worker-yyb55u-4ivg europe-west1-c RUNNING NONE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);