const regex = /.(?=Or)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.(?=Or)', 'gm')
const str = `AOrbOrCOrDOreOrdOr.Or`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);