using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[\w\s\\""]+(?<!\\)""";
string input = @"""a string"" ... ""another \""string\"" ... ""yet another \""string"" ... ""failed string\""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}