$re = '/^\|((\|[[:word:][:space:]]+)+?)\| +\|/m';
$str = '
+-----------------------------------------------------+
| Student Info |
|+----------------+--------------+-------------+ |
|| Name | Highschooled | County | |
|+----------------+--------------+-------------+ |
|| Rob | Y | LA | |
|+----------------+--------------+-------------+ |
| |
+-----------------------------------------------------+
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);