$re = '/^(?:(\d+)(?:h|H))?\s?(?:(\d+)(?:min|MIN))?$/m';
$str = '2H42MIN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);