const regex = /src\s*=\s*\\?['"](https?)?.+?abc\/sd.+?\\?['"]/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('src\\s*=\\s*\\\\?[\'"](https?)?.+?abc\\\/sd.+?\\\\?[\'"]', 'gi')
const str = `kkkkkkkkk src="https://abdcom/abc/sdp?a=a&ad=d\\" \\n <br> src=\\"/abc/sd\\" src='http:ab/abc/sdp' \\n ds src='http://ab/abc/sdp?bc=a'fdsfsds
src ='http//ab.com/abc/sdp' src=\\"./abc/sd\\" src=\\"../abc/sd\\"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}