$re = '/(?<=eh=")([^"]+)(?=")/';
$str = '\'zzzzzzz-------eh="koko"------eh="zizi"--------eh="mimi"--------xxxxxx\'
\'zzzzzzz----------eh="koko"-----------------eh="mimi"----------xxxxxx\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);