#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "destination=\K[^&]*"
Local $sString = "http://localhost/myweb/login/resend_password?destination=http://localhost%2Fmyweb%2Fsearch%3Fs%3Dislamic_sources%26q%3D%25D8%25B3%25D9%2584%25D8%25A7%25D9%2585"
Local $sSubst = "newval"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)