$re = '/^(?!.*\?)(.*?)\&(.*?)$/m';
$str = 'http://localohst/test/?lang=it&iframe=1&iframe=1
http://localohst/test/&lang=it&iframe=1&iframe=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);