re = /^([^\s\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)/
str = 'sample-search-cdn|nz|nz--cdn|||||generic-produce-luxury-gdn|||generic-value|||| '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end