import re
regex = re.compile(r".*?UserID=\"(?<UserID>.*?)\".*?UserName=\"(?<UserName>.*?)\".*?NetworkAccessPointID=\"(?<IPAddress>.*?)\".*?EventDateTime=\"(?<DateTime>.*?)\".*?EventOutcomeIndicator=\"(?<OutcomeIndicator>.*?)\".*?csd-code=\"(?<csd_code>.*?)\".*?AuditEnterpriseSiteID=\"(?<Site>.*?)\".*?ParticipantObjectID=\"(?<PatientID>.*?)\".*?ParticipantObjectTypeCode=\"(?<ObjectTypeCode>.*?)\".*?")
test_str = ("<AuditMessage xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">\n"
" <ActiveParticipant UserID=\"10361\" UserIsRequestor=\"true\" UserName=\"Alexander Hardin\" NetworkAccessPointID=\"184.190.165.174\" NetworkAccessPointTypeCode=\"2\" />\n"
" <EventIdentification EventDateTime=\"2022-08-15T04:26:37+0000\" EventOutcomeIndicator=\"0\" EventActionCode=\"R\">\n"
" <EventID codeSystemName=\"DCM\" csd-code=\"110110\" originalText=\"Patient Record\" />\n"
" </EventIdentification>\n"
" <AuditSourceIdentification AuditSourceID=\"Carepointe\" AuditEnterpriseSiteID=\"AZ\" />\n"
" <ParticipantObjectIdentification ParticipantObjectID=\"\" ParticipantObjectTypeCodeRole=\"1\" ParticipantObjectTypeCode=\"1\" ParticipantObjectDataLifeCycle=\"6\">\n"
" <ParticipantObjectIDTypeCode>2</ParticipantObjectIDTypeCode>\n"
" <ParticipantObjectQuery>U0VMRUNUIFVzZXJfSUQsIEZpcnN0TmFtZSwgTGFzdE5hbWUsIENvbXBhbnksIFJvbGVfSUQgRlJPTSB0YmxfdXNlcnMgV0hFUkUgVXNlcl9JRCA9IDp1aWQ=</ParticipantObjectQuery>\n"
" <ParticipantObjectDetail type=\"User_ID\" value=\"MTAzNjE=\" />\n"
" </ParticipantObjectIdentification>\n"
" <DICOMObjectDescriptionContents>\n"
" <Anonymized>0</Anonymized>\n"
" <Encrypted>0</Encrypted>\n"
" </DICOMObjectDescriptionContents>\n"
"</AuditMessage>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")