$re = '/then:.*(?!}])self|error:.*(?!}])self/ms';
$str = ' then:^id (NSNumber *isXtraUser) {
return val.val ? @"askdjh" : @"asldkj";
if(){[];}
self
}];
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);