$re = '/<[\S\s]*?>/i';
$str = '<a
href="things and stuff"
/>
<br>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);