re = /^[^>]+(?=>{2}.*$)/m
str = 'Transaction Value >> 100
Transaction Value >>> 100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end