# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\W{3}(\s|\s\s)(\«|\")\W{1,}\d+\W+\d+|(^\W+:|^.{1,}:)(\s|\s\s)\W{1,}\d{1,}\s\W{1,}\d{1,}(\s|\s\s)\W+)"
test_str = ("Сбербанк России ОАО г.Москва\n"
"Банк получателя\n"
"инн 502204278650\n"
"Внимание' Оплата данного счета означает согласие с условиями поставки товара. Уведомление об оплате\n"
"обязательно, в противном случае не гарантируется наличие товара на складе товар отпускается пс факту\n"
"прихода денег на prc Поставщика. самовывозам, при наличии довереанссти а паспорта\n"
"Образец заполнения платежного поручения\n"
"70 шт\n"
"кпп о\n"
"Сч. N?\n"
"Сч, N?\n"
"044525225\n"
"30101810400000000225\n"
"40802810740200101005\n"
"Краснова Татьяна Валерьевна”\n"
"Пол атель\n"
"Счет N? 196 от 17.12.08\n"
"инн 502204278650 КПП o\n"
"Поставщик:\n"
"“ИП Краснова Татьяна Валерьевна“\n"
"140411, Рф, Моск. обл.,г.Коломна,ул.Зеленая,д.ВА,кв.9\n"
"Покупатель: ИНН 5022017021 КПП 502201001 околоменский дом ребенка“\n"
"2\n"
"Товар\n"
"крем ЛАСКОВАЯ МАМА детский л 20мп Москва\n"
"Шампунь детский ЛАСКОВАЯ МАМА звомлг•пераое\n"
"шение“\" (Москва\n"
"КОЛ-ВО\n"
"96\n"
"Ед.\n"
"Цена\n"
"Итого:\n"
"Сумма\n"
"3360 ос\n"
"2Ђва 00\n"
"6'048.00\n"
"Всего наименований 2. на сумму 6048,00 руб.\n"
"Шесть тысяч сорок восемь рублей 00 копеек\n"
"Руководитель\n"
"[Краснова Т.В.}\n"
"Бухгалтер\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.