$re = '/(?<![\p{L}\p{N}_])gen/mu';
$str = 'To achieve this, I am using the regular expression /\\bsea/gmi, which works perfectly with English characters. However, it fails to produce the desired results when applied to Swedish characters, like \'ä\', \'å\', and \'ö\'. For example, if the search word is \'gen\', the postfix \'gen\' in the word \'vägen\' is incorrectly highlighted. It seems that the regular expression treats these characters as special characters or something similar. I even tried adding unicode modifier u but that didt\'t help either.
gen
gena
agen
ägen
genä
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);