package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\p{Z}`)
var str = `100 000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}