import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bopen\\s?file\\s+(\\S+)";
final String string = "Open File file.M_p3_23432e done\n"
+ "Openfile file.M_p4_6432e done\n"
+ "Open File file.M_p3_857432 done\n"
+ "Open File file.M_p4_34892f done\n"
+ "Openfile file.M_p3_781 done";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}