using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:<\/?\w+>)+|[^<>]+)";
string input = @"<b>Jeremi Stadler</b> at Auddly publishing has created song <i>Darkness</i> for you.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}