import re
regex = re.compile(r"(?i)(?:\w+\W+){0,9}?(?=.*(?:plot).*|.*(?:over).*)(?:\w+\W+){0,9}?(?=Charlie|Muir|Charlie Muir)\K(?:(?:Charlie|Muir|Charlie Muir)\s+)+", flags=re.MULTILINE)
test_str = ("\n"
"cHarlie muir charlie charlie was over the moon the the the the the tge the the the\n"
"-the the the the the the the the the the the the the the the the the-\n\n"
"over was the the the moon parker parker charlie muir charlie\n"
"-the the the the the the the the the the the the the the the the the-\n\n"
"Charlie muir charlie was near the plot\n"
"-the the the the the the the the the the the the the the the the the-\n\n"
"ChArlie was far away from the plot was far away from the\n"
"-the the the the the the the the the the the the the the the the the-\n\n"
"the plot was far away from CharLie\n"
"-the the the the the the the the the the the the the the the the the-\n\n"
"the plot was far away from CharLie muir charlie\n"
"-the the the the the the the the the the the the the the the the the-\n\n\n\n"
"the over was far away from CHarlie muir\n"
"-the the the the the the the the the the the the the the the the the-\n\n"
"Mr cHARLIE was bowled over test was bowled after the ball\n"
"-the the the the the the the the the the the the the the the the the-\n\n"
"over the test was bowled muIR\n"
"-the the the the the the the the the the the the the the the the the-\n\n"
"the plot the ball the slot it will plot the test was bowled MuiR\n"
"-the the the the the the the the the the the the the the the the the-\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")