import re
regex = re.compile(r"^(\((\d{3})\)|(\d{3}))[\s\-\.]?\d{3}[\s\-\.]?\d{4}", flags=re.MULTILINE)
test_str = ("678 9o2 65o1\n"
"33 43 269413\n"
"(716)5 262238\n"
"(334)7 21-0630\n"
"256-462-6615\n"
"256 462 6615\n"
"72 47 36 7976\n"
"(681)2 433259\n"
"256-462-6615\n"
"7✴two✴0✴six✴four✴nine✴2✴zero✴7✴eight\n"
"(302)4 872364\n\n"
"678 NO TROUBLE NO GAMES 964 RLEAXIN SPACE JUST TO GET AWAY Wettness your taste buds needs 0656\n\n"
"2❤#TWO 0❤ZERO5 ❤FIVE 5❤FIVE 2❤TWO 6❤SIX 8❤EIGHTY 7❤SEVEN 1❤ONE SIX 6\n\n"
"720/838/8032")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")