import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{4})?\\/(?:(?:\\d\\d)?\\/){2}(?:[A-Za-z\\s-]+)?$";
final String string = "2020/06/25/XYZConf\n"
+ "2020///XYZConf\n"
+ "2020//25/XYZConf\n"
+ "2020/06//XYZConf\n"
+ "//25/XYZConf\n"
+ "///";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}