re = /[2-9][0-9][/
str = '
drwxrwxr-x - testetl hdp_test 0 2018-02-02 05:10 /raw/ADS/ClicksData/click/datetm=2017-10-15
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:35 /raw/ADS/ClicksData/click/datetm=2017-10-16
drwxrwxr-x - testetl hdp_test 0 2018-01-31 21:54 /raw/ADS/ClicksData/click/datetm=2017-10-17
drwxrwxr-x - testetl hdp_test 0 2018-01-31 23:59 /raw/ADS/ClicksData/click/datetm=2017-10-18
drwxrwxr-x - testetl hdp_test 0 2018-01-31 21:49 /raw/ADS/ClicksData/click/datetm=2017-10-19
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:32 /raw/ADS/ClicksData/click/datetm=2017-10-20
drwxrwxr-x - testetl hdp_test 0 2018-02-02 11:51 /raw/ADS/ClicksData/click/datetm=2017-10-21
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:08 /raw/ADS/ClicksData/click/datetm=2017-10-22
drwxrwxr-x - testetl hdp_test 0 2018-01-31 22:42 /raw/ADS/ClicksData/click/datetm=2017-10-23
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:58 /raw/ADS/ClicksData/click/datetm=2017-10-24
drwxrwxr-x - testetl hdp_test 0 2018-02-02 05:10 /raw/ADS/ClicksData/click/datetm=2017-10-25
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:46 /raw/ADS/ClicksData/click/datetm=2017-10-26
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:04 /raw/ADS/ClicksData/click/datetm=2017-10-27
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:46 /raw/ADS/ClicksData/click/datetm=2017-10-28
drwxrwxr-x - testetl hdp_test 0 2018-02-02 00:21 /raw/ADS/ClicksData/click/datetm=2017-10-29
drwxrwxr-x - testetl hdp_test 0 2018-02-02 05:09 /raw/ADS/ClicksData/click/datetm=2017-10-30
drwxrwxr-x - testetl hdp_test 0 2018-02-02 05:13 /raw/ADS/ClicksData/click/datetm=2017-10-31
drwxrwxr-x - testetl hdp_test 0 2018-02-01 14:34 /raw/ADS/ClicksData/click/datetm=2017-11-01
drwxrwxr-x - testetl hdp_test 0 2018-02-02 09:20 /raw/ADS/ClicksData/click/datetm=2017-11-02
drwxrwxr-x - testetl hdp_test 0 2018-02-01 14:35 /raw/ADS/ClicksData/click/datetm=2017-11-03
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:42 /raw/ADS/ClicksData/click/datetm=2017-11-04
drwxrwxr-x - testetl hdp_test 0 2018-02-02 09:18 /raw/ADS/ClicksData/click/datetm=2017-11-05
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:11 /raw/ADS/ClicksData/click/datetm=2017-11-06
drwxrwxr-x - testetl hdp_test 0 2018-01-31 17:56 /raw/ADS/ClicksData/click/datetm=2017-11-07
drwxrwxr-x - testetl hdp_test 0 2018-01-31 21:36 /raw/ADS/ClicksData/click/datetm=2017-11-08
drwxrwxr-x - testetl hdp_test 0 2018-01-31 16:43 /raw/ADS/ClicksData/click/datetm=2017-11-09
drwxrwxr-x - testetl hdp_test 0 2018-01-31 21:59 /raw/ADS/ClicksData/click/datetm=2017-11-10
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:23 /raw/ADS/ClicksData/click/datetm=2017-11-11
drwxrwxr-x - testetl hdp_test 0 2018-02-02 09:15 /raw/ADS/ClicksData/click/datetm=2017-11-12
drwxrwxr-x - testetl hdp_test 0 2018-02-01 00:32 /raw/ADS/ClicksData/click/datetm=2017-11-13
drwxrwxr-x - testetl hdp_test 0 2018-02-02 00:23 /raw/ADS/ClicksData/click/datetm=2017-11-14
drwxrwxr-x - testetl hdp_test 0 2018-02-02 08:57 /raw/ADS/ClicksData/click/datetm=2017-11-15
drwxrwxr-x - testetl hdp_test 0 2018-01-31 22:40 /raw/ADS/ClicksData/click/datetm=2017-11-16
drwxrwxr-x - testetl hdp_test 0 2018-02-02 05:09 /raw/ADS/ClicksData/click/datetm=2017-11-17
drwxrwxr-x - testetl hdp_test 0 2018-02-02 05:08 /raw/ADS/ClicksData/click/datetm=2017-11-18
drwxrwxr-x - testetl hdp_test 0 2018-01-31 22:59 /raw/ADS/ClicksData/click/datetm=2017-11-19
drwxrwxr-x - testetl hdp_test 0 2018-01-31 21:44 /raw/ADS/ClicksData/click/datetm=2017-11-20
drwxrwxr-x - testetl hdp_test 0 2018-01-31 20:08 /raw/ADS/ClicksData/click/datetm=2017-11-21
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:12 /raw/ADS/ClicksData/click/datetm=2017-11-22
drwxrwxr-x - testetl hdp_test 0 2018-02-02 11:52 /raw/ADS/ClicksData/click/datetm=2017-11-23
drwxrwxr-x - testetl hdp_test 0 2018-01-31 22:57 /raw/ADS/ClicksData/click/datetm=2017-11-24
drwxrwxr-x - testetl hdp_test 0 2018-01-31 21:57 /raw/ADS/ClicksData/click/datetm=2017-11-25
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:28 /raw/ADS/ClicksData/click/datetm=2017-11-26
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:22 /raw/ADS/ClicksData/click/datetm=2017-11-27
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:04 /raw/ADS/ClicksData/click/datetm=2017-11-28
drwxrwxr-x - testetl hdp_test 0 2018-01-31 05:28 /raw/ADS/ClicksData/click/datetm=2017-11-29
drwxrwxr-x - testetl hdp_test 0 2018-01-31 23:59 /raw/ADS/ClicksData/click/datetm=2017-11-30
drwxrwxr-x - testetl hdp_test 0 2018-01-31 23:57 /raw/ADS/ClicksData/click/datetm=2017-12-01
drwxrwxr-x - testetl hdp_test 0 2018-01-31 22:43 /raw/ADS/ClicksData/click/datetm=2017-12-02
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:28 /raw/ADS/ClicksData/click/datetm=2017-12-03
drwxrwxr-x - testetl hdp_test 0 2018-02-01 00:54 /raw/ADS/ClicksData/click/datetm=2017-12-04
drwxrwxr-x - testetl hdp_test 0 2018-02-02 08:54 /raw/ADS/ClicksData/click/datetm=2017-12-05
drwxrwxr-x - testetl hdp_test 0 2018-02-02 08:52 /raw/ADS/ClicksData/click/datetm=2017-12-06
drwxrwxr-x - testetl hdp_test 0 2018-02-01 07:23 /raw/ADS/ClicksData/click/datetm=2017-12-07
drwxrwxr-x - testetl hdp_test 0 2018-02-01 07:21 /raw/ADS/ClicksData/click/datetm=2017-12-08
drwxrwxr-x - testetl hdp_test 0 2018-02-06 11:39 /raw/ADS/ClicksData/click/datetm=2017-12-09
drwxrwxr-x - testetl hdp_test 0 2018-01-31 22:31 /raw/ADS/ClicksData/click/datetm=2017-12-10
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:57 /raw/ADS/ClicksData/click/datetm=2017-12-11
drwxrwxr-x - testetl hdp_test 0 2018-01-31 22:22 /raw/ADS/ClicksData/click/datetm=2017-12-12
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:13 /raw/ADS/ClicksData/click/datetm=2017-12-13
drwxrwxr-x - testetl hdp_test 0 2018-01-31 16:33 /raw/ADS/ClicksData/click/datetm=2017-12-14
drwxrwxr-x - testetl hdp_test 0 2018-01-31 23:49 /raw/ADS/ClicksData/click/datetm=2017-12-15
drwxrwxr-x - testetl hdp_test 0 2018-02-02 05:24 /raw/ADS/ClicksData/click/datetm=2017-12-16
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:42 /raw/ADS/ClicksData/click/datetm=2017-12-17
drwxrwxr-x - testetl hdp_test 0 2018-02-02 08:59 /raw/ADS/ClicksData/click/datetm=2017-12-18
drwxrwxr-x - testetl hdp_test 0 2018-02-01 14:36 /raw/ADS/ClicksData/click/datetm=2017-12-19
drwxrwxr-x - testetl hdp_test 0 2018-02-02 05:10 /raw/ADS/ClicksData/click/datetm=2017-12-20
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:43 /raw/ADS/ClicksData/click/datetm=2017-12-21
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:13 /raw/ADS/ClicksData/click/datetm=2017-12-22
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:06 /raw/ADS/ClicksData/click/datetm=2017-12-23
drwxrwxr-x - testetl hdp_test 0 2018-02-02 09:14 /raw/ADS/ClicksData/click/datetm=2017-12-24
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:03 /raw/ADS/ClicksData/click/datetm=2017-12-25
drwxrwxr-x - testetl hdp_test 0 2018-01-31 22:37 /raw/ADS/ClicksData/click/datetm=2017-12-26
drwxrwxr-x - testetl hdp_test 0 2018-02-01 14:34 /raw/ADS/ClicksData/click/datetm=2017-12-27
drwxrwxr-x - testetl hdp_test 0 2018-02-02 05:12 /raw/ADS/ClicksData/click/datetm=2017-12-28
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:32 /raw/ADS/ClicksData/click/datetm=2017-12-29
drwxrwxr-x - testetl hdp_test 0 2018-01-31 18:00 /raw/ADS/ClicksData/click/datetm=2017-12-30
drwxrwxr-x - testetl hdp_test 0 2018-01-31 21:45 /raw/ADS/ClicksData/click/datetm=2017-12-31
drwxrwxr-x - testetl hdp_test 0 2018-02-02 05:08 /raw/ADS/ClicksData/click/datetm=2018-01-01
drwxrwxr-x - testetl hdp_test 0 2018-02-01 00:32 /raw/ADS/ClicksData/click/datetm=2018-01-02
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:43 /raw/ADS/ClicksData/click/datetm=2018-01-03
drwxrwxr-x - testetl hdp_test 0 2018-02-02 05:10 /raw/ADS/ClicksData/click/datetm=2018-01-04
drwxrwxr-x - testetl hdp_test 0 2018-02-01 14:34 /raw/ADS/ClicksData/click/datetm=2018-01-05
drwxrwxr-x - testetl hdp_test 0 2018-02-02 09:01 /raw/ADS/ClicksData/click/datetm=2018-01-06
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:29 /raw/ADS/ClicksData/click/datetm=2018-01-07
drwxrwxr-x - testetl hdp_test 0 2018-02-01 08:59 /raw/ADS/ClicksData/click/datetm=2018-01-08
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:45 /raw/ADS/ClicksData/click/datetm=2018-01-09
drwxrwxr-x - testetl hdp_test 0 2018-02-01 08:57 /raw/ADS/ClicksData/click/datetm=2018-01-10
drwxrwxr-x - testetl hdp_test 0 2018-01-31 23:59 /raw/ADS/ClicksData/click/datetm=2018-01-11
drwxrwxr-x - testetl hdp_test 0 2018-02-01 14:36 /raw/ADS/ClicksData/click/datetm=2018-01-12
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:29 /raw/ADS/ClicksData/click/datetm=2018-01-13
drwxrwxr-x - testetl hdp_test 0 2018-01-31 22:57 /raw/ADS/ClicksData/click/datetm=2018-01-14
drwxrwxr-x - testetl hdp_test 0 2018-01-31 22:35 /raw/ADS/ClicksData/click/datetm=2018-01-15
drwxrwxr-x - testetl hdp_test 0 2018-01-31 21:49 /raw/ADS/ClicksData/click/datetm=2018-01-16
drwxrwxr-x - testetl hdp_test 0 2018-02-02 11:51 /raw/ADS/ClicksData/click/datetm=2018-01-17
drwxrwxr-x - testetl hdp_test 0 2018-02-01 07:24 /raw/ADS/ClicksData/click/datetm=2018-01-18
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:46 /raw/ADS/ClicksData/click/datetm=2018-01-19
drwxrwxr-x - testetl hdp_test 0 2018-02-02 09:22 /raw/ADS/ClicksData/click/datetm=2018-01-20
drwxrwxr-x - testetl hdp_test 0 2018-02-01 08:29 /raw/ADS/ClicksData/click/datetm=2018-01-21
drwxrwxr-x - testetl hdp_test 0 2018-02-02 08:55 /raw/ADS/ClicksData/click/datetm=2018-01-22
drwxrwxr-x - testetl hdp_test 0 2018-02-01 08:29 /raw/ADS/ClicksData/click/datetm=2018-01-23
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:58 /raw/ADS/ClicksData/click/datetm=2018-01-24
drwxrwxr-x - testetl hdp_test 0 2018-01-31 21:46 /raw/ADS/ClicksData/click/datetm=2018-01-25
drwxrwxr-x - testetl hdp_test 0 2018-02-01 09:14 /raw/ADS/ClicksData/click/datetm=2018-01-26
drwxrwxr-x - testetl hdp_test 0 2018-02-01 02:16 /raw/ADS/ClicksData/click/datetm=2018-01-27
drwxrwxr-x - testetl hdp_test 0 2018-02-02 05:12 /raw/ADS/ClicksData/click/datetm=2018-01-28
drwxrwxr-x - testetl hdp_test 0 2018-02-01 00:59 /raw/ADS/ClicksData/click/datetm=2018-01-29
drwxrwxr-x - testetl hdp_test 0 2018-02-06 11:41 /raw/ADS/ClicksData/click/datetm=2018-01-30
drwxrwxr-x - testetl hdp_test 0 2018-02-06 13:48 /raw/ADS/ClicksData/click/datetm=2018-01-31
drwxrwxr-x - testetl hdp_test 0 2018-02-06 13:48 /raw/ADS/ClicksData/click/datetm=2018-02-01
drwxrwxr-x - testetl hdp_test 0 2018-02-06 20:24 /raw/ADS/ClicksData/click/datetm=2018-02-02
drwxrwxr-x - testetl hdp_test 0 2018-02-06 19:26 /raw/ADS/ClicksData/click/datetm=2018-02-03
drwxrwxr-x - testetl hdp_test 0 2018-02-06 19:26 /raw/ADS/ClicksData/click/datetm=2018-02-04
drwxrwxr-x - testetl hdp_test 0 2018-02-06 19:26 /raw/ADS/ClicksData/click/datetm=2018-02-05
drwxrwxr-x - testetl hdp_test 0 2018-02-06 21:23 /raw/ADS/ClicksData/click/datetm=2018-02-06
drwxrwxr-x - testetl hdp_test 0 2018-02-07 20:41 /raw/ADS/ClicksData/click/datetm=2018-02-07
drwxrwxr-x - testetl hdp_test 0 2018-02-08 20:46 /raw/ADS/ClicksData/click/datetm=2018-02-08
drwxrwxr-x - testetl hdp_test 0 2018-02-09 21:17 /raw/ADS/ClicksData/click/datetm=2018-02-09
drwxrwxr-x - testetl hdp_test 0 2018-02-10 21:34 /raw/ADS/ClicksData/click/datetm=2018-02-10
drwxrwxr-x - testetl hdp_test 0 2018-02-11 20:53 /raw/ADS/ClicksData/click/datetm=2018-02-11
drwxrwxr-x - testetl hdp_test 0 2018-02-12 23:06 /raw/ADS/ClicksData/click/datetm=2018-02-12
drwxrwxr-x - testetl hdp_test 0 2018-02-13 22:23 /raw/ADS/ClicksData/click/datetm=2018-02-13
drwxrwxr-x - testetl hdp_test 0 2018-02-14 23:50 /raw/ADS/ClicksData/click/datetm=2018-02-14
drwxrwxr-x - testetl hdp_test 0 2018-02-15 23:10 /raw/ADS/ClicksData/click/datetm=2018-02-15
drwxrwxr-x - testetl hdp_test 0 2018-02-16 21:53 /raw/ADS/ClicksData/click/datetm=2018-02-16
drwxrwxr-x - testetl hdp_test 0 2018-02-17 21:57 /raw/ADS/ClicksData/click/datetm=2018-02-17
drwxrwxr-x - testetl hdp_test 0 2018-02-18 21:59 /raw/ADS/ClicksData/click/datetm=2018-02-18
drwxrwxr-x - testetl hdp_test 0 2018-02-19 22:09 /raw/ADS/ClicksData/click/datetm=2018-02-19
drwxrwxr-x - testetl hdp_test 0 2018-02-20 09:13 /raw/ADS/ClicksData/click/datetm=2018-02-20
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end