re = /(?<=\{\{)[^}]+(?=\}\})/i
str = 'маша ела {{кактус}} и умерла от {{смеха}}.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end