using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(baulera|guardamuebles)";
string input = @"DEPARTAMENTO DE CATEGORIA EN EXCELENTE ESTADO EN BELGRANO //4 AMBIENTES CON COCHERA, DEPENDENCIA DE SERVICIO Y BAULERA /MUY LUMINOSO, PISO ALTO, CON VISTA ABIERTA / COMODO, SILENCIOSO, EXCELENTE DISTRIBUCION / TODOS LOS AMBIENTES DAN AL EXTERIOR /EDIFICIO EN TORRE CON SEGURIDAD LAS 24HS / AMPLIO ESPACIO VERDE PARA DISPERSION Y JUEGOS PARA NIÑOS / EDIFICIO DE 25 PISOS / SEMIPISOS /JOSE HERNANDEZ AL 2000, ENTRE O'HIGGINS Y ARCOS //PISO: 8vo, AL FRENTE, ORIENTACION NORESTE //VALOR DE VENTA: U$S 450.000 //EXPENSAS: $15.500 / SUPERFICIE TOTAL: 144M2 /SUPERFICIE CUBIERTA: 134 M2 + BALCONES /AMPLIO LIVING COMEDOR /3 DORMITORIOS, EL PRINCIPAL EN SUITE / 2DO BAÑO COMPLETO /GRAN COCINA - COMEDOR / LAVADERO /DEPENDENCIA DE SERVICIO (CON SU RESPECTIVO BAÑO) / 2 BALCONES /BAULERA AMPLIA /COCHERA CUBIERTA Y FIJA / CALEFACCION POR LOSA RADIANTE / MUY BUENA UBICACIÓN: CERCANO A LAS AVENIDAS CABILDO, DEL LIBERTADOR, LUIS MARIA CAMPOS, JURAMENTO Y FEDERICO LACROZE. CERCANIA A ESPACIOS VERDES (BARRANCAS DE BELGRANO Y PLAZA MANUEL BELGRANO). ZONA COMERCIAL (A POCAS CUADRAS DE CABILDO Y JURAMENTO) Y DE COLEGIOS. A POCAS CUADRAS DEL SOLAR DE LA ABADIA Y DEL HOSPITAL MILITAR.CON MÚLTIPLES MEDIOS DE TRANSPORTE: INCLUIDO CERCANIA AL SUBTE LINEA ""D"" (ESTACIÓN JOSE HERNANDEZ) Y EL FC. MITRE (ESTACIÓN BELGRANO C). //
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}