#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]*([а-яА-Яё\,\. \(\)\-]+([0-9]+)?)+"
Local $sString = "деревня Николо-Хованское, 217, поселение Сосенское, Москва" & @CRLF & _
"улица Алымова 5" & @CRLF & _
"Улица Народного Ополчения 45 (со стороны д. 47)" & @CRLF & _
"Ул. Большая Филёвская, д. 3, к. 4" & @CRLF & _
"Большая Филевская 3к4, подъезд 3" & @CRLF & _
"Большая филевска улица д3к4" & @CRLF & _
"Большая Филевская 3к4" & @CRLF & _
"Большая Филёвская 3к4" & @CRLF & _
"Большая филевская 3к4" & @CRLF & _
"Большая Филевская 3к4" & @CRLF & _
"Большая Филевская дом 3 корпус 4 , 3 подъезд" & @CRLF & _
"Большая Филевская 3к4" & @CRLF & _
"Большая Филевская 3к4" & @CRLF & _
"Большая Филевская 3к4" & @CRLF & _
"Врачебный проезд 3" & @CRLF & _
"Парковка рядом с домами ул. Коптевская, д. 20к2 и ул. Коптевская, д. 18Ак3" & @CRLF & _
"Улица Планерная 12" & @CRLF & _
"деревня Николо-Хованское, 200соор1, поселение Сосенское, Москва" & @CRLF & _
"Улица 1905 года 25" & @CRLF & _
"2" & @CRLF & _
"Большая Филевская, дом 3, корпус 4" & @CRLF & _
"Погонный проезд 12к1" & @CRLF & _
"Москва, поселение Первомайское, д. Каменка, ул. Кленовая, д.1А, стр.1" & @CRLF & _
"Большая Филевская 3 кор 4, подъезд 3" & @CRLF & _
"Ул.Новочеремушкинская д.31" & @CRLF & _
"Новопесчаная д2А" & @CRLF & _
"Большая Якиманка 52 двор" & @CRLF & _
"сельскохозяйственная ул 20, к 2" & @CRLF & _
"Сельскохозяйственная 20 к3" & @CRLF & _
"Сельскохозяйственная 20к2" & @CRLF & _
"Кронштадтский бульвар, парковочные карманы вдоль владения 6 (порядка 300 м)" & @CRLF & _
"Плющиха 9 стр 2" & @CRLF & _
"Руставели 15б" & @CRLF & _
"1" & @CRLF & _
"Весенняя д. 4" & @CRLF & _
"Москва, Поселение Новофедоровское, квартал 180. Координаты: 55.448734, 36.977061" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"Погонный проезд, 12к1" & @CRLF & _
"Погонный проезд, 12к1" & @CRLF & _
"Ул. Раздельная" & @CRLF & _
"Деревня Саларьево улица 1-Ая Новая д 7/2 кадастровый номер 77:17:0110301:336" & @CRLF & _
"12-я парковая 5 и 12-я парковая 7" & @CRLF & _
"Алтуфьевское шоссе 27 напротив тц лучик" & @CRLF & _
"Алтуфьевское шоссе 27 вначале дома" & @CRLF & _
"Сумской проезд 12/5" & @CRLF & _
"Погонный проезд, 12к1" & @CRLF & _
"4" & @CRLF & _
"Беговая 4" & @CRLF & _
"Цветной бульвар дом 21стр.1" & @CRLF & _
"Ул Василия Петушкова 20, к.1" & @CRLF & _
"Москва, улица Первомайская, дом 100" & @CRLF & _
"Ул. Раздельная" & @CRLF & _
"Город Москва, улица Мясницкая, дом 22, строение 1. Вход во двор со стороны Банковского переулка." & @CRLF & _
"Воронцовская 26" & @CRLF & _
"Чусовская улица 17/40" & @CRLF & _
"Героев Панфиловцев 17 к2" & @CRLF & _
"Спартаковский переулок 24с2" & @CRLF & _
"Красных зорь 33а" & @CRLF & _
"Берсеневская набережная, 14с5" & @CRLF & _
"Проезд Черского 21б" & @CRLF & _
"Героев Панфиловцев 17 к2" & @CRLF & _
"Проезд Шокальского, 15" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")