use strict;
my $str = 'Deutsche Post AG
~ Test Str. 176
12345 Entenhausen
81014617 0873 08.09.2021 15:50
Sendungs informa tionen:
123456789012
DHL Retoure
oe Re 8 oe 6 0 BE MERe ob pre eo Ste eo en ec ONO woes
Sendungsverfolgung unter:
wow. dhl. de/sendungsverfolgung
Vielen Dank fiir Ihren Besuch.
Ihre Deutsche Post AG
me x
';
my $regex = qr/(\b\d{12}\b)(?:.*[\n]{0,3}.*DHL.*Retoure)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}