re = /^(?:.*?\|){10}(.*?)\|/m
str = 'Info device Allow:FWD|TCP|data1|data2|data3|data4|data5|data6|data7|data8|data9|data10|data11|0|1|0|0|0|0||||||
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end