import Foundation
let pattern = #".+AES:.+?:.+?!.+?,.+?,.+?,.+?,.+?,\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
00:16:0808-11-20AES:AE022AGES:022.60032S!20FINI/ID60032S,BLUE01,ZPR008A21308/MR1,2/AFLPLA,KPSM/TD071030,10325053
01:30:0808-11-20AES:AE20C7GES:442.77186A!H1G-#MDINI/ID77186A,RCH356,AAM18131E306/MR0,0/AFLPLA,KPSM/TD070705,113038C4
19:37:0708-11-20AES:AE1472GES:822.77180A!H1N-#MDINI/ID77180A,RCH871,AJRF3368F313/MR1,0/AFFJDG,OAIX/TD081130,1059997B
20:49:0908-11-20AES:AE123AGES:822.44128A!H1P-#MDINI/ID44128A,RCH836,AJZA3362C312/MR0,0/AFFJDG,OKAS/TD081245,1245C15B
04:16:0508-11-20AES:AE0580GES:D02.70035B!33F/AMCTACC.INI01081215INITIALIZERCH551MC0035ABR02Y5XD313KDOVLERT081400/
22:33:0708-11-20AES:AE10BFGES:822.10196A!H1D-#MDINI/ID10196A,RCH873,JJRF3361F312/MR0,0/AFRODN,FJDG/TD071355,135525BA
22:47:0908-11-20AES:AE117EGES:822.21112A!H1C-#MDINI/ID21112A,RCH877,JJZA3363C312/MR0,0/AFFJDG,OKAS/TD081345,1345F5F3
07:32:0808-11-20AES:AE0243GES:022.80047S!20G01/Y/MC/0047/08/KIAB/KSVN/1701/0000/SNAP85//6A9E
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)