#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\[)(.+)(?<=\])(.+)"
Local $sString = "[30-05-2013 15:45:54] A A" & @CRLF & _
"[26-06-2013 14:44:44] B A" & @CRLF & _
"[26-06-2013 14:44:44] C A" & @CRLF & _
"[26-06-2013 14:43:16] Some lines are so large, they take multiple lines, so explode('\n') won't work because" & @CRLF & _
"I need the complete message" & @CRLF & _
"[26-06-2013 14:44:44] E A" & @CRLF & _
"[26-06-2013 14:44:44] F A" & @CRLF & _
"[26-06-2013 14:44:44] G A" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")