$re = '/(http\S+)\/(\s|$)/';
$str = 'https://www.something.com/here/postname/
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;