import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=filename=\"Myfile\\.pdf\")\\s+((?:\\S+\\s)+\\S+)=";
final String string = "--------------A5B0A8B4F69F8BD959B758D0\n"
+ "Content-Type: application/pdf;\n"
+ " name=\"Myfile.pdf\"\n"
+ "Content-Transfer-Encoding: base64\n"
+ "Content-Disposition: attachment;\n"
+ " filename=\"Myfile.pdf\"\n\n"
+ "JVBERi0xLjQKJeLjz9MKMyAwIG9iago8PC9UeXBlL1hPYmplY3QvQ29sb3JT\n"
+ "ZWI0ODRmNDE1ZDE0YmIyZmU2YjAzZDMzNjU+PGU5MDFiZTMzY2FlOTY4ZDM2\n"
+ "NmFmOGNhOTUxNTE0Nzk0Pl0vSW5mbyAyMyAwIFIvU2l6ZSAyND4+CnN0YXJ0\n"
+ "eHJlZgoyMzg2NgolJUVPRgo=\n\n"
+ "--------------A5B0A8B4F69F8BD959B758D0--";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}