# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?=[^)(]*\))/./gm;t' <<< "room_ass=01:macro_id=01: name=Left, pgm_audio=0, usb=0, list=(1*,3,5,7,),
room_ass=01:macro_id=02: name=Right, pgm_audio=1, usb=1, list=(2*,4,6,8,),
room_ass=01:macro_id=03: name=All, pgm_audio=1, list=(1,2*,3,4,5,6,7,8,),"