import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<w-block-content.*[\\s\\S]*?<div>)([\\s\\S]*?)(?:<\\/div>((?!<\\/div>))*[\\s]*?<\\/span>[\\s\\S]*?<\\/w-block-content>)";
final String string = "</tr>\n"
+ " <td>\n"
+ " <div draggable=\"true\" class=\"source master draggable-box wysiwyg-block\" data-block-type=\"master\" data-block-id=\"96e80afb-afa0-4e46-bfb7-34b80da76112\" style=\"opacity: 1;\">\n"
+ " <w-block-content data-block-content-id=\"96e80afb-afa0-4e46-bfb7-34b80da76112\"><span class=\"source-block-tooltip\">\n"
+ " <div>\n\n"
+ "Další master<br><div><b>Master č. 2</b> </div><br>\n\n"
+ " </div>\n"
+ " </span></w-block-content>\n"
+ " </div>\n"
+ " </td>\n"
+ " </tr>\n"
+ "</tr>\n"
+ " <td>\n"
+ " <div draggable=\"true\" class=\"source master draggable-box wysiwyg-block\" data-block-type=\"master\" data-block-id=\"96e80afb-afa0-4e46-bfb7-34b80da76112\" style=\"opacity: 1;\">\n"
+ " <w-block-content data-block-content-id=\"96e80afb-afa0-4e46-bfb7-34b80da76112\"><span class=\"source-block-tooltip\">\n"
+ " <div>\n\n"
+ "Další master<br><b>Master č. 2</b><br>\n"
+ " \n"
+ " </div>\n"
+ " </span></w-block-content>\n"
+ " </div>\n"
+ " </td>\n"
+ " </tr>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}