#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:SLF4J:|\w+(?:\.\w+)+).*(?:\R(?!(?:SLF4J:|\w+(?:\.\w+)+)|{).*)*"
Local $sString = "SLF4J: Class path contains multiple SLF4J bindings." & @CRLF & _
"SLF4J: Found binding in [jar:file:/opt/spark/jars/logback-classic-1.2.3.jar!/org/slf4j/impl/StaticLoggerBinder.class]" & @CRLF & _
"SLF4J: Found binding in [jar:file:/opt/spark/jars/slf4j-log4j12-1.7.30.jar!/org/slf4j/impl/StaticLoggerBinder.class]" & @CRLF & _
"SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation." & @CRLF & _
"SLF4J: Actual binding is of type " & @CRLF & _
"{"log_timestamp": "2021-02-18T11:33:23.114+0000", "log_level": "WARN", "process_id": "zookeeper#2", "process_name": "zookeeper", "thread_id": 1, "thread_name": "QuorumPeer[myid=2](plain=/0.0.0.0:2181)(secure=disabled)", "action_name": "org.apache.zookeeper.server.quorum.QuorumPeer", "log_message": "PeerState set to LOOKING"}" & @CRLF & _
"{"log_timestamp": "2021-02-18T11:33:23.115+0000", "log_level": "WARN", "process_id": "zookeeper#2", "process_name": "zookeeper", "thread_id": 1, "thread_name": "WorkerSender[myid=2]", "action_name": "org.apache.zookeeper.server.quorum.QuorumPeer", "log_message": "Failed to resolve address: zk-2.zk-headless.intam.svc.cluster.local"}" & @CRLF & _
"java.net.UnknownHostException: zk-2.zk-headless.intam.svc.cluster.local" & @CRLF & _
" at java.net.InetAddress.getAllByName0(InetAddress.java:1281)" & @CRLF & _
" at java.net.InetAddress.getAllByName(InetAddress.java:1193)" & @CRLF & _
" at java.net.InetAddress.getAllByName(InetAddress.java:1127)" & @CRLF & _
" at java.net.InetAddress.getByName(InetAddress.java:1077)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.QuorumPeer$QuorumServer.recreateSocketAddresses(QuorumPeer.java:194)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.QuorumPeer.recreateSocketAddresses(QuorumPeer.java:764)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.QuorumCnxManager.connectOne(QuorumCnxManager.java:699)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.QuorumCnxManager.toSend(QuorumCnxManager.java:618)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.FastLeaderElection$Messenger$WorkerSender.process(FastLeaderElection.java:477)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.FastLeaderElection$Messenger$WorkerSender.run(FastLeaderElection.java:456)" & @CRLF & _
" at java.lang.Thread.run(Thread.java:748)" & @CRLF & _
"{"log_timestamp": "2021-02-18T11:33:23.115+0000", "log_level": "WARN", "process_id": "zookeeper#2", "process_name": "zookeeper", "thread_id": 1, "thread_name": "WorkerSender[myid=2]", "action_name": "org.apache.zookeeper.server.quorum.QuorumPeer", "log_message": "Failed to resolve address: zk-2.zk-headless.sxc.svc.cluster.local"}" & @CRLF & _
"" & @CRLF & _
"java.lang.InterruptedException: Timeout while waiting for epoch from quorum" & @CRLF & _
" at org.apache.zookeeper.server.quorum.Leader.getEpochToPropose(Leader.java:1227)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.Leader.lead(Leader.java:482)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.QuorumPeer.run(QuorumPeer.java:1284)" & @CRLF & _
" ... 19 more" & @CRLF & _
"{"log_timestamp": "2021-02-18T11:33:23.114+0000", "log_level": "WARN", "process_id": "zookeeper#2", "process_name": "zookeeper", "thread_id": 1, "thread_name": "QuorumPeer[myid=2](plain=/0.0.0.0:2181)(secure=disabled)", "action_name": "org.apache.zookeeper.server.quorum.QuorumPeer", "log_message": "PeerState set to LOOKING"}" & @CRLF & _
"{"log_timestamp": "2021-02-18T11:33:23.115+0000", "log_level": "WARN", "process_id": "zookeeper#2", "process_name": "zookeeper", "thread_id": 1, "thread_name": "WorkerSender[myid=2]", "action_name": "org.apache.zookeeper.server.quorum.QuorumPeer", "log_message": "Failed to resolve address: zk-2.zk-headless.intam.svc.cluster.local"}" & @CRLF & _
"java.net.UnknownHostException: zk-2.zk-headless.intam.svc.cluster.local" & @CRLF & _
" at java.net.InetAddress.getAllByName0(InetAddress.java:1281)" & @CRLF & _
" at java.net.InetAddress.getAllByName(InetAddress.java:1193)" & @CRLF & _
" at java.net.InetAddress.getAllByName(InetAddress.java:1127)" & @CRLF & _
" at java.net.InetAddress.getByName(InetAddress.java:1077)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.QuorumPeer$QuorumServer.recreateSocketAddresses(QuorumPeer.java:194)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.QuorumPeer.recreateSocketAddresses(QuorumPeer.java:764)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.QuorumCnxManager.connectOne(QuorumCnxManager.java:699)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.QuorumCnxManager.toSend(QuorumCnxManager.java:618)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.FastLeaderElection$Messenger$WorkerSender.process(FastLeaderElection.java:477)" & @CRLF & _
" at org.apache.zookeeper.server.quorum.FastLeaderElection$Messenger$WorkerSender.run(FastLeaderElection.java:456)" & @CRLF & _
" at java.lang.Thread.run(Thread.java:748)" & @CRLF & _
"{"log_timestamp": "2021-02-18T11:33:23.115+0000", "log_level": "WARN", "process_id": "zookeeper#2", "process_name": "zookeeper", "thread_id": 1, "thread_name": "WorkerSender[myid=2]", "action_name": "org.apache.zookeeper.server.quorum.QuorumPeer", "log_message": "Failed to resolve address: zk-2.zk-headless.sxc.svc.cluster.local"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"org.apache.zookeeper.server.quorum.QuorumCnxManager.connectOne(QuorumCnxManager.java:699) dorg.apache.zookeeper.server.quorum.QuorumCnxManager.connectOne(QuorumCnxManorg.apache.zookeeper.server.quorum.QuorumCnxManager.connectOne(QuorumCnxManager.java:699)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")