$re = '%<div\s+class="asd"> # match an opening \'div\' with an id that starts with \'t\' and some digits
[^<>]* # match zero or more chars other than \'<\' and \'>\'
( # open group 1
<div[^>]*> # match an opening \'div\'
(?: # open a non-matching group
[^<>]* # match zero or more chars other than \'<\' and \'>\'
| # OR
(?1) # recursively match what is defined by group 1
)* # close the non-matching group and repeat it zero or more times
</div> # match a closing \'div\'
) # close group 1
[^<>]* # match zero or more chars other than \'<\' and \'>\'
</div> %msix';
$str = '<div>
<div class="asd">
<div>
<div>
Hello
</div>
</div>
</div>
</div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);