$re = '/[n-n-N](.+)[g-g-G](.+)([r-r-R]|[a-a-A]|among us free)/m';
$str = 'nigeria';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);