$re = '/(?<=\d\s).+$/m';
$str = 'learn 10 functions
Watch 3 YT tutorial videos
complete 10 charts';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);