$re = '/@\w+/';
$str = 'Example response <@U7J3C4AKB|john.doe> from slack';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);