$re = '/(RGT|UYT|WWB)-[\d]{4}\s\|\s[a-zA-Z0-9\s]*/m';
$str = 'RGT-1234 | Here are is my change';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);