package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(HH12|HH)+`)
var str = `HH12HH`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}