$re = '/(https?):\/\/([a-zA-Z0-9._%\/]+)/mx';
$str = 'qsdflkjqsd flkqjsflk jdqqsdfq https://monsite.fr/ma_page_web.php qldfjqdkljf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);