re = /(?m)^[A-Z]{2,3}\.[0-9]{2}\.[0-9]{3}\b\s*(.*)/m
str = 'Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry\'s standard
AB.00.000 My Text Content
$!#"!
23:50
My Phone'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end