using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"btn(?<!\.btn)\s";
string input = @"btn or .btn ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}