import re
regex = re.compile(r"(?<=\b(?:aa|ab|ace|ach|ady|aeb|ae|af|akk|als|am|ang|an|ar-latn|ary|arz|ar|ast|as|atj|avk|ay|az|ban|bar|ba|bcl|be-tarask|ber|be|bg|bh|bia|bi|bjn|bm|bn|bo|bpy|br|bs|bua|bxm|bxr|bxu|ca|cbk|ceb|ce|ch|ckb|cmn|cnr-cyrl|cnr-latn|cnr|co|cpf|crh|crs|cr|cs|cv|cy|dag|dak|da|de|dta|dv|dyu|dz|ee|egl|ekk|el|en-gb|en-us|en|eo|es|eto|et|eu|ext|fa|ff|fil|fi|fj|fo|fr-be|fr1835|frm|fro|frp|fr|fud|fur|fy|gag|ga|gcf-mq|gcf|gd|gez|gil|gl|gn|got|grc|gsw-ch|gsw-fr|gsw|gu|gv|hak|haw|ha|he|hif|hi|hr|hsb|ht|hu|hyw|hy|hz|ia|id|ie|ig|ii|ik|ilo|io|is|it|iu|ja-latn|ja|jv|kaa|kab|kaw|ka|kbd|kea|kg|ki|kk-arab|kk-cyrl|kk-latn|kk|kl|kmr|km|kn|ko|ksh|ks|ku|kv|kw|ky|kzg|lad|lang:mi|lang:mr|lang:nb|lang:non|lang:ve|la|lb|lfn|lij|li|lld|lmo|ln|lob|lou|lo|ltc|lt|lua|luo|lv|lzh|mey|mfe|mga|mg|mhr|mh|mk-cyrl|mk-latn|mk|ml|mn-cyrl|mn-latn|mn-mong|mnc|mn|moh|mo|mqm|mrq|ms|mt|mug|mus|mvf|mwl|myv|my|nah|nan|nap|naq|na|nds-nl|nds|nd|new|ne|niu|nl-be|nl|nn|no|nrf-je|nrf|nr|nso|nv|ny|och|oc|okn|om|or|osp|os|ota|otk|pal|pam|pap|pau|pa|pcd|pdc|pis|pi|pl|pms|pnt|prk|prs|ps|pt-br|pt|qu|rap|rar|rmy|rm|ro|ru-latn|rue|run|rup|ru|rw|ryu|sa|scn|sco|sc|sd|se|sga|sgs|sg|shy|sh|simple|si|sjo|sk|sli|slr|sl|smi|sm|snk|sn|so|sq|sr|ssf|st|su|sv|sw|syc|syr|szl|ta|tet|te|tg|th|ti|tk|tl|tmr|tn|tok|to|tpi|tr|tsg|ts|tts|tt|tvl|tw|tyv|ty|tzl|udm|ug|uhn|uk|ur|uz|vec|vep|vi|vls|vo|vro|war|wa|wls|woe|wo|wuu|xh|xmm|xsl|yak|yi|yoi|yo|yue|za|zea|zgh|zh-cn|zh-hans|zh-hant|zh-hk|zh-latn-pinyin|zh-mo|zh-sg|zh-tw|zh|zu|zza)\b) *}} *{{ *(?=\b(?:aa|ab|ace|ach|ady|aeb|ae|af|akk|als|am|ang|an|ar-latn|ary|arz|ar|ast|as|atj|avk|ay|az|ban|bar|ba|bcl|be-tarask|ber|be|bg|bh|bia|bi|bjn|bm|bn|bo|bpy|br|bs|bua|bxm|bxr|bxu|ca|cbk|ceb|ce|ch|ckb|cmn|cnr-cyrl|cnr-latn|cnr|co|cpf|crh|crs|cr|cs|cv|cy|dag|dak|da|de|dta|dv|dyu|dz|ee|egl|ekk|el|en-gb|en-us|en|eo|es|eto|et|eu|ext|fa|ff|fil|fi|fj|fo|fr-be|fr1835|frm|fro|frp|fr|fud|fur|fy|gag|ga|gcf-mq|gcf|gd|gez|gil|gl|gn|got|grc|gsw-ch|gsw-fr|gsw|gu|gv|hak|haw|ha|he|hif|hi|hr|hsb|ht|hu|hyw|hy|hz|ia|id|ie|ig|ii|ik|ilo|io|is|it|iu|ja-latn|ja|jv|kaa|kab|kaw|ka|kbd|kea|kg|ki|kk-arab|kk-cyrl|kk-latn|kk|kl|kmr|km|kn|ko|ksh|ks|ku|kv|kw|ky|kzg|lad|lang:mi|lang:mr|lang:nb|lang:non|lang:ve|la|lb|lfn|lij|li|lld|lmo|ln|lob|lou|lo|ltc|lt|lua|luo|lv|lzh|mey|mfe|mga|mg|mhr|mh|mk-cyrl|mk-latn|mk|ml|mn-cyrl|mn-latn|mn-mong|mnc|mn|moh|mo|mqm|mrq|ms|mt|mug|mus|mvf|mwl|myv|my|nah|nan|nap|naq|na|nds-nl|nds|nd|new|ne|niu|nl-be|nl|nn|no|nrf-je|nrf|nr|nso|nv|ny|och|oc|okn|om|or|osp|os|ota|otk|pal|pam|pap|pau|pa|pcd|pdc|pis|pi|pl|pms|pnt|prk|prs|ps|pt-br|pt|qu|rap|rar|rmy|rm|ro|ru-latn|rue|run|rup|ru|rw|ryu|sa|scn|sco|sc|sd|se|sga|sgs|sg|shy|sh|simple|si|sjo|sk|sli|slr|sl|smi|sm|snk|sn|so|sq|sr|ssf|st|su|sv|sw|syc|syr|szl|ta|tet|te|tg|th|ti|tk|tl|tmr|tn|tok|to|tpi|tr|tsg|ts|tts|tt|tvl|tw|tyv|ty|tzl|udm|ug|uhn|uk|ur|uz|vec|vep|vi|vls|vo|vro|war|wa|wls|woe|wo|wuu|xh|xmm|xsl|yak|yi|yoi|yo|yue|za|zea|zgh|zh-cn|zh-hans|zh-hant|zh-hk|zh-latn-pinyin|zh-mo|zh-sg|zh-tw|zh|zu|zza)\b)", flags=re.MULTILINE)
test_str = ("{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}\n"
"{{aa}} {{ab}} machintruc\n"
"brun}} {{aa}} {{ab}}\n"
"{{fr}} {{en}} {{de}} [http//truc]\n"
"{{fi}} {{ luo }} {{ en-gb }} {{ zh-hant }}{{chapitre|\n"
"{{de}}{{nl}}{{fi}} {{ luo }} {{ en-gb }} {{ zh-hant }} {{lien web|\n"
"{{mr}} Trucmuche\n")
subst = "|"
result = regex.sub(subst, test_str)
if result:
print(result)