re = /<(a)(?(?!match)[^>])+>[^<]*<\/\1>/
str = 'текст 1
<a class="btn" href="https://site.ru/">Ссылка1</a>
текст 2
<a class="btn" href="https://match.com">Ссылка2</a>
текст 3
<a class="btn" href="https://fall.com/">Ссылка3</a>
текст 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end