$re = '/(?i)<i(?!mg)[^>]*>/m';
$str = '<i>
<ind value="abc">
<img/src=x onerror=alert("stack..!")>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);